近几日发现了几个小坑

请注意,本文编写于 176 天前,最后修改于 38 天前,其中某些信息可能已经过时。

1.Java11以上去除了对EE的支持,故无法正常安装Android SDK

解决办法:没有解决办法,降级吧,Java新版本的新特新绝大多数人用不到(片面的说道),JDK8挺好用的(要是可以我还要安Java13

2.Python的“turtle”图形库对3.x支持较差,甚至部分情况会出现无法安装的情况(多是在Linux和Mac环境下)

解决办法:找了一圈,最后在Terminal的提示里看到一句话,大概意思是说

“setup.py这玩意的第四十行有个问题”

立马打开,发现一个函数没有加括号(Python3新特性?),加上后,紧接这来了一套“pip3 install -e packagefile”,解决问题。

3.MacOS 10.15 Catalina(目前最新GM版本),对Anaconda3不友好,在运行效率和包管理方面问题较多

解决办法:解决办法?有啥解决办法?等苹果大爷release正式版和anaconda的更新呗。我能有啥办法,MacOS又没和谐回滚(莫名其妙开始怀念Windows?)。

4.Ruby Gem 一定记得要换国内的源!

解决办法:百度,然后换呗,推荐用阿里云或是清华的(当然中科大的什么的都行,不挑)。

5.Conda一定要换国内的源!(pip/pip3随便了,换了肯定更好一点)

解决办法:和上条一样,但更推荐用清华的。之前清华的镜像下线过一次,但这次上线清华官方宣称:“我们和官方达成协议啦!”

6.Gradle/Flutter一定要换国内的源!

解决办法:方法依旧如上,但是有一个点需要留心,一般Flutter的Gradle会出现两次,一次是项目里的Android目录下,另一次是在Flutter的tools里面目录还有一个Gradle的配置文件,都需要改,并且在项目的Gradle中,除了依赖(dependency),还有“allproject”。

7.Mac用户用Flutter做iOS开发一定要吧cocoapods的流程走完

解决办法:用Flutter的人肯定生疏不了“flutter doctor”,只是提醒一下,记得在“gem install cocoapods”完成后,再跟上一句pod setup

8.MySQL5.x升级到8.0以上版本(Windows环境,自用Windows10 2004)

https://noheart.cn/archives/mysqlupdate 这篇内容相当不错

添加新评论